Regulator replaced - reset didn't work

krikee

New Member
Messages
2
#1
Re Alfa Spider - My regulator was replaced with genuine Alfa Part (or so I was told). Window works but in reverse of what it should - ie instead of going down few cms when opening/shutting door window will go fully up down when opening & shutting door. I can use switch to move window up and down slightly but need to close door to get it to go fully up if it has been opened fully. The centre roof opening switch will only make the window go down and then will not operate the roof as it senses an "error". I have done the reset but note in my manual that it should have been done firstly with the doors closed. Unfortunately the mechanics worked on it with the door open. I have lookoed thru forums and found plenty of resets that worked but nothing works for me. Do I have to undo the battery or dismantle the door and reassemble things to get it to reset?
 

Smaky

New Member
Messages
161
#3
Re Alfa Spider - My regulator was replaced with genuine Alfa Part (or so I was told). Window works but in reverse of what it should - ie instead of going down few cms when opening/shutting door window will go fully up down when opening & shutting door. I can use switch to move window up and down slightly but need to close door to get it to go fully up if it has been opened fully. The centre roof opening switch will only make the window go down and then will not operate the roof as it senses an "error". I have done the reset but note in my manual that it should have been done firstly with the doors closed. Unfortunately the mechanics worked on it with the door open. I have lookoed thru forums and found plenty of resets that worked but nothing works for me. Do I have to undo the battery or dismantle the door and reassemble things to get it to reset?
Remove the plug from the regulator, and swap the pins for the wires over in the plug
.
 

krikee

New Member
Messages
2
#4
Thanks to those that responded. It's all fixed. Wires were correctly replaced in the door. We disconnected and reconnected the battery and then did the window reset with the DOORS CLOSED. This was the problem the first time around, we had the door open at the mechanics. Did the 3 second reset and voila. All that is not working now is the auto up on the drivers side window, it goes down in one hit when holding down but I don't care. I can easily live with that.
 
Messages
5,494
#5
Thanks to those that responded. It's all fixed. Wires were correctly replaced in the door. We disconnected and reconnected the battery and then did the window reset with the DOORS CLOSED. This was the problem the first time around, we had the door open at the mechanics. Did the 3 second reset and voila. All that is not working now is the auto up on the drivers side window, it goes down in one hit when holding down but I don't care. I can easily live with that.
Fantastic news :) Do we get any pics of the bella??