Alfa 33s 16v QV P4 (Forza)

Andrei.QV

New Member
Messages
26
Hello everybody, I'm Andrei from Romania and I'm the happy owner of an 33 Permanent 4. I'll start with a short history of the car, I've bought it in 2009 after it sat for 5 years somewhere in Germany, because of some missing papers I couldn't register it in Romania but I've made the necessary efforts in order to register it on some dude's name in Bulgaria (bribes bla bla bla), now I have all the necessary Bulgarian documents to register it in Romania but I decided to start a nice restoration which I will come back to later. When I bought the car I was pretty young and idiotic, I've done plenty of stuff to ruin the car a couple of times(no accidents), first of all I've had a pretty skillful 2'd to 1st gear at 110km/h , the car did 12k revs or so, there were some noises but I've discovered that the engine had no real damage, the noises came from the pin where the crankshaft and the flywheel fit, it had broken out, basically this engine did 12k rpm and had almost no damage. I've decided to rebuild the engine though. I've worked on the engine with my father in our garage, bought best parts for the engine (goetze etc) and decided to have a nice breaking for the engine. After 1000 I decided to go on the highway to test how the engine deals with high speeds, this resulted in the prop shaft intermediary to fly from under my car at around 200km/h (no idea why) and while doing that the prop shaft also broke my connection between the gear leaver and the gearbox. Because I was 110 km away from home I had to remove all the gear leaver **** in the car, get my hand through the whole and switch in 4th with my bare hand in order to get home, of course when I got in the city I had to switch again to second. I've got some new parts from AO and there I have it, my car was again 4x4. I've had a nice trip with the car, 3500 KM totally, I've driven to Turkey on holiday, the car did not break at all, really cool trip I might add. I've driven it until the first snow had fallen, I've drifted it a bit in the snow and the next day, what do you know, It wouldnt start! Thinking that there might be frozen water in the fuel filter (-20 outside) I've let the car still until the spring came when I've investigated the problem and I had 0 compression on 2 cylinders. After opening the engine I've realised that the cylinder head were not fit strong enough therefore there was water all over my cylinder head and in the cylinder itself. Because the water spent so much time in the engine I've discovered that the car had really big damage on the cylinders and I've decided to buy a damaged SW 16v in order to take the engine off it. The car was in a really bad shape but the engine had never been opened and had 100k KM, I'm currently driving the SW while restoring my P4. At this point my P4 is STRIPPED to the bone, the only thing left on the car is the suspension setup and the wheels, I've bought new brakes (even repair kits for all the break parts), I'll get PU bushes, basically I've bought A LOT OF PARTS, all the sensors for example, I will tell you more about it when the car will be painted and I'll start fitting stuff in to it. Currently my problems are the p4 speedo (I really wanna fix it because its the original speedo of the car, 160k KM) and there are some noises in the gearbox (like clutch bearing but its not the clutch bearing). Sorry for the long post guys, I'll attach some photos of the car. The car has kony + H&R suspension setup and 16 inch Borbet rims (from a Lancia therefore I had to make some improvisation on the logo). I'll attach photos with the car when it was in a good shape, I'll come back with some photos from during restoration(before restoration the car wasn't in a great shape)
 

Attachments

Andrei.QV

New Member
Messages
26
Haha thanks mate! I'll take them to MRCAP for some nice cleaning as soon as I'm almost finished with the car. I'll start posting some photos with my car from before the restoring and after later today! Please someone who has powerflex on his P4, TEACH ME MASTER!
 

conaero

Forum Owner
Messages
29,464
Welcome Andrei, loving the 33, its a car that is on my radar at the moment.

All the best.
 

Supercharged16v

New Member
Messages
558
Why are you specifically asking for powerflex on the P4 ?

What would you like to know / what are your concerns ?
 

Andrei.QV

New Member
Messages
26
Powerflex informed me that the bushes on the rear (8 of them) wont fit directly on P4 because the P4 bushes are larges, therefore I need to make some adapting (which I have no ideea how to do as I dont posses the bushes yet) I quote "he set can also be used for Alfa 33s with allwheel-drive (4x4, Permanent 4, Q4) with the restriction that the OEM bushes for the front bars of the watts linkage have a larger diametre and the PU-bushes will not fit there without the help of a specially made sleeve. "
 

Supercharged16v

New Member
Messages
558
Well, actually, this is not what I understood by reading this quote :)

The only difference in the bushes is the front sway bar/ stabilizer that is on the crossmember
But you can always keep yours on that one and dont buy the corresponding powerflex pieces for those ;)
 

Andrei.QV

New Member
Messages
26
Yea that's a more optimistic way of looking at it, I'll see when they arrive :). @ Conaero thanks for the warm welcoming, I love the forum but I've failed to find the rule which states what resolution the photos that I upload must be, could someone help me with that please?
 

Supercharged16v

New Member
Messages
558
Andrei,

you have 1GB of upload space. If you are using Microsoft Picture Manager to resize your pictures, I suggest you make them 1024x768 res, so they will be at about 200 KB or less with an 8mp camera - approximately.

Dont worry, they will look very good when uploaded on that resolution, unless you are viewing them on a 55" TV ! hahaha

So the less the picture size, the more pictures you can upload in total ;)

Makes sense ?
 

Andrei.QV

New Member
Messages
26
1gb is really resonable, a BIT better than the 5mb that AO offers :frusty5:. So basicly there is no resolution standard just the size matters, I think that in 1gb of space I can even post 2mp photos (full hd that means)
 

conaero

Forum Owner
Messages
29,464
No need to resize the images, they are done to a width of 800px on the fly when you upload them.
 

Andrei.QV

New Member
Messages
26
Time to post some photos from the before "era" I'll be back with photos from the restoration (up to date).
 

Attachments

Andrei.QV

New Member
Messages
26
I hope this wont be considered spam :) Here are the photos almost up to date with the restoration. LE: Seems I've messed up a bit adding some photos twice.
 

Attachments

Last edited:

Supercharged16v

New Member
Messages
558
Very good job Andrei :excellent:

I saw some pictures here I havent seen before.

...like the one where you tilted the car on one side and supported it with a piece of wood :omg:

I wouldnt work under that if you paid me ! hahahaha

Brave man :thumb1:
 

Andrei.QV

New Member
Messages
26
Hahaha the car is actually supported by a barrel covered in many rubber car mats(on the other side, next photo) !!! This part of the restoration was done by the painter who also is a metal man, welder whatever, he is pretty good at it too :p
 

Andrei.QV

New Member
Messages
26
I've found some rust that the painter/rust guy left in the windshield area so I've had to fix it myself, not much rust but definitely had to be fixed. While doing so I've damaged the paint on the A pillar (very very little) so I might repaint the A pillar on the left side. I've received the rear bumper and I've put it on the car temporary, looks great I'm really happy with it, what annoys me though is the fact that my old door ornaments look like C R A P!!! I've got to find them new because the old ones are rubbish, I hope I'll be able to find them new... The photo with the Forrest has a dramatic effect, this is how it looks when I start working on the car at 8 AM :)
 

Attachments